clwn.net
当前位置:首页 >> 编译安装php5.6 so文件在哪 >>

编译安装php5.6 so文件在哪

php安装的最后一步make install时,我们会看到将动态链接库libphp5.so拷贝到apache2的安装目录的modules目录下,并且还需要在httpd.conf配置文件中添加LoadModule语句来动态将libphp5.so模块加载进来,从而实现Apache对php的支持。

由于好久没有搭环境,在Linux上搭apache、PHP的环境时,遇到libphp5.so 无法生成这个问题,我也困扰了我半天,很是郁闷。从网上找了各种资料,都是瞎转载,太无聊的一堆人了,自己成功没有成功的先转载,鄙视。 害的我尝试了半天也没有解决。下...

1 libphp5.so是php5提供的, 2 你还需要编译php5才能生成这个文件 你在PHP的configure的时候,加上: --with-apxs2=/usr/local/apache/bin/apxs 这样就会自动编译一个libphp5.so出来了。

configure_php.sh #!/bin/bash ./configure \ --prefix=/png/php/7.0.0 \ --enable-opcache \ --enable-fpm \ --enable-pdo \ --enable-sockets \ --enable-exif \ --enable-soap \ --enable-ftp \ --enable-wddx \ --enable-pcntl \ --enable-s...

1 libphp5.so是php5提供的, 2 你还需要编译php5才能生成这个文件 你在PHP的configure的时候,加上: --with-apxs2=/usr/local/apache/bin/apxs 这样就会自动编译一个libphp5.so出来了。你试试看行不行, 你还不明白的话可以去后盾网去问问专家...

重新编译加上参数 --with-openssl ,就OK,如果本地没有openssl支持,在config的checker阶段会过不去的 =================== 相关过程如下 # 下载到/var/www/php5目录下 cd /var/www/php5 wget http://mirrors.sohu.com/php/php-5.2.14.tar.gz #...

[Raykaeso@LAMP httpd-2.4.17]# cd /LAMP [Raykaeso@LAMP LAMP]# yum -y install libxml2-devel #不装这个编译不了PHP5.6 [Raykaeso@LAMP LAMP]# yum -y install libjpeg libjpeg-devel libpng libpng-devel freetype freetype-devel png jpeg g...

方法如下 talk is cheap,show me the code: [root@LAMP1 lib]# php -vPHP 5.3.3 (cli) (built: Oct 30 2014 20:12:53) Copyright (c) 1997-2010 The PHP GroupZend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies[root@LAMP1 lib]#...

** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:1-4.0.4.2-9.el6.x86_64 has missing requires of libjawt.so()(64bit)

用yum install libtool-libs 或 yum install libtool-ltdl-devel 补充安装可搞定。

网站首页 | 网站地图
All rights reserved Powered by www.clwn.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com